Command Injection Vulnerability with Mercurial in VCS
CVE-2022-21235GHSA-6635-c626-vj4r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/Masterminds/vcs 1.13.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.13.2
- Fixed in
- 1.13.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6635-c626-vj4r lists affected ranges: Go github.com/Masterminds/vcs >=0 <1.13.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-21235: 1.58% estimated exploitation activity in the next 30 days; percentile 75.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
URLs and local file paths passed to the Mercurial (hg) APIs that are specially crafted can contain commands which are executed by Mercurial if it is installed on the host operating system. The vcs package uses the underly version control system, in this case hg, to implement the needed functionality. When hg is executed, argument strings are passed to hg in a way that additional flags can be set. The additional flags can be used to perform a command injection. Other version control systems with an implemented interface may also be vulnerable. The issue has been fixed in version 1.13.2. A work around is to sanitize data passed to the vcs package APIs to ensure it does not contain commands or unexpected data. This is important for user input data that is passed directly to the package APIs.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6635-c626-vj4r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-21235 Advisory: Command Injection Vulnerability with Mercurial in VCS IDs: CVE-2022-21235, GHSA-6635-c626-vj4r Record: https://patchnext.com/advisories/cve-2022-21235 (revision 1, source checked 26 Oct 2026, 15:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/Masterminds/vcs 1.13.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/Masterminds/vcs: affected < 1.13.2; fixed in 1.13.2 ## Suggested inspection (read-only) - Go github.com/Masterminds/vcs: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/Masterminds/vcs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6635-c626-vj4r (GitHub-reviewed advisory GHSA-6635-c626-vj4r lists affected ranges: Go github.com/Masterminds/vcs >=0 <1.13.2) Commands are suggestions: review each one before running it.
Loading voting…