Denial-of-Service when binding invalid parameters in sqlite3
CVE-2022-21227GHSA-9qrh-qjmc-5w2p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sqlite3 5.0.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm sqlite3
- Affected
- >= 5.0.0, < 5.0.3
- Fixed in
- 5.0.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9qrh-qjmc-5w2p lists affected ranges: npm sqlite3 >=5.0.0 <5.0.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9qrh-qjmc-5w2p lists affected ranges: npm sqlite3 >=5.0.0 <5.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2022-21227: 2.21% estimated exploitation activity in the next 30 days; percentile 82.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected versions of sqlite3 will experience a fatal error when supplying a specific object in the parameter array. This error causes the application to crash and could not be caught. Users of sqlite3 v5.0.0, v5.0.1 and v5.0.2 are affected by this. This issue is fixed in v5.0.3. All users are recommended to upgrade to v5.0.3 or later. Ensure there is sufficient sanitization in the parent application to protect against invalid values being supplied to binding parameters as a workaround.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9qrh-qjmc-5w2p
- Revision 1 · created ·
Published from osv record GHSA-9qrh-qjmc-5w2p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-21227 Advisory: Denial-of-Service when binding invalid parameters in sqlite3 IDs: CVE-2022-21227, GHSA-9qrh-qjmc-5w2p Record: https://patchnext.com/advisories/cve-2022-21227 (revision 2, source checked 26 Oct 2026, 12:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sqlite3 5.0.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm sqlite3: affected >= 5.0.0, < 5.0.3; fixed in 5.0.3 ## Suggested inspection (read-only) - `npm ls sqlite3 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sqlite3. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9qrh-qjmc-5w2p (OSV record GHSA-9qrh-qjmc-5w2p lists affected ranges: npm sqlite3 >=5.0.0 <5.0.3 (fixed)) - Verified: https://github.com/advisories/GHSA-9qrh-qjmc-5w2p (GitHub-reviewed advisory GHSA-9qrh-qjmc-5w2p lists affected ranges: npm sqlite3 >=5.0.0 <5.0.3) Commands are suggestions: review each one before running it.
Loading voting…