Skip to content

← Actionable
Critical, CVSS 9.8amended

Prototype Pollution in convict

CVE-2022-21190GHSA-jjf5-wx3j-3fv7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (convict 6.2.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm convict

    Affected
    < 6.2.3
    Fixed in
    6.2.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-21190: 3.97% estimated exploitation activity in the next 30 days; percentile 90.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

This affects the package convict before 6.2.3. This is a bypass of CVE-2022-22143. The fix introduced, relies on the startsWith method and does not prevent the vulnerability: before splitting the path, it checks if it starts with proto or this.constructor.prototype. To bypass this check it's possible to prepend the dangerous paths with any string value followed by a dot, like for example foo.proto or foo.this.constructor.prototype.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-jjf5-wx3j-3fv7

  2. Revision 1 · created ·

    Published from osv record GHSA-jjf5-wx3j-3fv7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-21190

Advisory: Prototype Pollution in convict
IDs: CVE-2022-21190, GHSA-jjf5-wx3j-3fv7
Record: https://patchnext.com/advisories/cve-2022-21190 (revision 2, source checked 26 Oct 2026, 12:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: convict 6.2.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm convict: affected < 6.2.3; fixed in 6.2.3

## Suggested inspection (read-only)
- `npm ls convict --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on convict.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jjf5-wx3j-3fv7 (OSV record GHSA-jjf5-wx3j-3fv7 lists affected ranges: npm convict >=0 <6.2.3 (fixed))
- Verified: https://github.com/advisories/GHSA-jjf5-wx3j-3fv7 (GitHub-reviewed advisory GHSA-jjf5-wx3j-3fv7 lists affected ranges: npm convict >=0 <6.2.3)

Commands are suggestions: review each one before running it.

Loading voting…