Skip to content

← Actionable
High, CVSS 7.3amended

Prototype Pollution in Dexie

CVE-2022-21189GHSA-3xgx-r9j4-qw9w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (dexie 4.0.0-alpha.3, 3.2.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm dexie

    Affected
    < 3.2.2>= 4.0.0-alpha.1, <= 4.0.0-alpha.2
    Fixed in
    3.2.2, 4.0.0-alpha.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2022-21189: 1.71% estimated exploitation activity in the next 30 days; percentile 77.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Dexie is a minimalistic wrapper for IndexedDB. The package dexie before 3.2.2, from 4.0.0-alpha.1 and before 4.0.0-alpha.3 are vulnerable to Prototype Pollution in the Dexie.setByKeyPath(obj, keyPath, value) function which does not properly check the keys being set (like proto or constructor). This can allow an attacker to add/modify properties of the Object.prototype leading to prototype pollution vulnerability. Note: This vulnerability can occur in multiple ways, for example when modifying a collection with untrusted user input.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3xgx-r9j4-qw9w

  2. Revision 1 · created ·

    Published from osv record GHSA-3xgx-r9j4-qw9w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-21189

Advisory: Prototype Pollution in Dexie
IDs: CVE-2022-21189, GHSA-3xgx-r9j4-qw9w
Record: https://patchnext.com/advisories/cve-2022-21189 (revision 2, source checked 26 Oct 2026, 12:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dexie 4.0.0-alpha.3, 3.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm dexie: affected < 3.2.2; >= 4.0.0-alpha.1, <= 4.0.0-alpha.2; fixed in 3.2.2, 4.0.0-alpha.3

## Suggested inspection (read-only)
- `npm ls dexie --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dexie.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3xgx-r9j4-qw9w (OSV record GHSA-3xgx-r9j4-qw9w lists affected ranges: npm dexie >=0 =4.0.0-alpha.1 <4.0.0-alpha.3 (fixed))
- Verified: https://github.com/advisories/GHSA-3xgx-r9j4-qw9w (GitHub-reviewed advisory GHSA-3xgx-r9j4-qw9w lists affected ranges: npm dexie >=0 =4.0.0-alpha.1 <=4.0.0-alpha.2)

Commands are suggestions: review each one before running it.

Loading voting…