express-xss-sanitizer vulnerable to Prototype Pollution via allowedTags attribute
CVE-2022-21169GHSA-grjp-4jmr-mjcw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (express-xss-sanitizer 1.1.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.1.3
- Fixed in
- 1.1.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-grjp-4jmr-mjcw lists affected ranges: npm express-xss-sanitizer >=0 <1.1.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-grjp-4jmr-mjcw lists affected ranges: npm express-xss-sanitizer >=0 <1.1.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2022-21169: 0.95% estimated exploitation activity in the next 30 days; percentile 61.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The package express-xss-sanitizer before 1.1.3 is vulnerable to Prototype Pollution via the allowedTags attribute, allowing the attacker to bypass xss sanitization.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-grjp-4jmr-mjcw
- Revision 1 · created ·
Published from osv record GHSA-grjp-4jmr-mjcw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-21169 Advisory: express-xss-sanitizer vulnerable to Prototype Pollution via allowedTags attribute IDs: CVE-2022-21169, GHSA-grjp-4jmr-mjcw Record: https://patchnext.com/advisories/cve-2022-21169 (revision 2, source checked 26 Oct 2026, 12:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: express-xss-sanitizer 1.1.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm express-xss-sanitizer: affected < 1.1.3; fixed in 1.1.3 ## Suggested inspection (read-only) - `npm ls express-xss-sanitizer --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on express-xss-sanitizer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-grjp-4jmr-mjcw (OSV record GHSA-grjp-4jmr-mjcw lists affected ranges: npm express-xss-sanitizer >=0 <1.1.3 (fixed)) - Verified: https://github.com/advisories/GHSA-grjp-4jmr-mjcw (GitHub-reviewed advisory GHSA-grjp-4jmr-mjcw lists affected ranges: npm express-xss-sanitizer >=0 <1.1.3) Commands are suggestions: review each one before running it.
Loading voting…