Unrestricted Attachment Upload
CVE-2022-2111GHSA-fr2w-mp56-g4xp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (inventree 0.7.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI inventree
- Affected
- < 0.7.2
- Fixed in
- 0.7.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fr2w-mp56-g4xp lists affected ranges: PyPI inventree >=0 <0.7.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fr2w-mp56-g4xp lists affected ranges: PyPI inventree >=0 <0.7.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-2111: 1.24% estimated exploitation activity in the next 30 days; percentile 69.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact InvenTree allows unrestricted upload of files as attachments to various database fields. Potentially dangerous files (such as HTML files containing malicious javascript) can be uploaded, and (when opened by the user) run the malicious code directly in the users browser. Note that the upload of malicious files must be performed by an authenticated user account Solution The solution for this vulnerability is to ensure that attachment files are downloaded to the local machine before opening, rather than opening the file in the current browser context. Patches - The issue is addressed in the upcoming 0.8.0 release - This fix will also be back-ported to the 0.7.x branch, applied to the 0.7.2 release Workarounds Users can alleviate risk of opening malicious files by right-clicking on the attachment link and selecting "Save link as" This minimizes risk (e.g. of XSS attacks) by opening the HTML file from the users computer References…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-fr2w-mp56-g4xp
- Revision 1 · created ·
Published from osv record GHSA-fr2w-mp56-g4xp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-2111 Advisory: Unrestricted Attachment Upload IDs: CVE-2022-2111, GHSA-fr2w-mp56-g4xp Record: https://patchnext.com/advisories/cve-2022-2111 (revision 2, source checked 26 Oct 2026, 13:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: inventree 0.7.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI inventree: affected < 0.7.2; fixed in 0.7.2 ## Suggested inspection (read-only) - `python -m pip show inventree`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on inventree. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-fr2w-mp56-g4xp (OSV record GHSA-fr2w-mp56-g4xp lists affected ranges: PyPI inventree >=0 <0.7.2 (fixed)) - Verified: https://github.com/advisories/GHSA-fr2w-mp56-g4xp (GitHub-reviewed advisory GHSA-fr2w-mp56-g4xp lists affected ranges: PyPI inventree >=0 <0.7.2) Commands are suggestions: review each one before running it.
Loading voting…