Skip to content

← Actionable
Medium, CVSS 4.3

Incorrect Permission Assignment for Critical Resource in Jenkins Bitbucket Branch Source Plugin

CVE-2022-20618GHSA-w2mh-6xj5-f77f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins:cloudbees-bitbucket-branch-source 746.v350d2781c184, 725.vd9f8be0fa250, 2.9.11.2, 2.9.7.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-w2mh-6xj5-f77f lists affected ranges: Maven org.jenkins-ci.plugins:cloudbees-bitbucket-branch-source >=726.v7e6f53de133c =720.vbe985dd73d66 =2.9.8 =0 <2.9.7.2

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2022-20618: 0.85% estimated exploitation activity in the next 30 days; percentile 58.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Jenkins Bitbucket Branch Source Plugin prior to 746.v350d2781c184, 725.vd9f8be0fa250, 2.9.11.2, and 2.9.7.2 does not perform permission checks in several HTTP endpoints. This allows attackers with Overall/Read access to enumerate credentials IDs of credentials stored in Jenkins. Those can be used as part of an attack to capture the credentials using another vulnerability. An enumeration of credentials IDs in Bitbucket Branch Source Plugin 746.v350d2781c184, 725.vd9f8be0fa250, 2.9.11.2, and 2.9.7.2 requires the appropriate permissions.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-w2mh-6xj5-f77f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-20618

Advisory: Incorrect Permission Assignment for Critical Resource in Jenkins Bitbucket Branch Source Plugin
IDs: CVE-2022-20618, GHSA-w2mh-6xj5-f77f
Record: https://patchnext.com/advisories/cve-2022-20618 (revision 1, source checked 26 Oct 2026, 16:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins:cloudbees-bitbucket-branch-source 746.v350d2781c184, 725.vd9f8be0fa250, 2.9.11.2, 2.9.7.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.jenkins-ci.plugins:cloudbees-bitbucket-branch-source: affected >= 726.v7e6f53de133c, < 746.v350d2781c184; >= 720.vbe985dd73d66, < 725.vd9f8be0fa250; >= 2.9.8, < 2.9.11.2; < 2.9.7.2; fixed in 2.9.7.2, 2.9.11.2, 746.v350d2781c184, 725.vd9f8be0fa250

## Suggested inspection (read-only)
- Maven org.jenkins-ci.plugins:cloudbees-bitbucket-branch-source: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.jenkins-ci.plugins:cloudbees-bitbucket-branch-source.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-w2mh-6xj5-f77f (GitHub-reviewed advisory GHSA-w2mh-6xj5-f77f lists affected ranges: Maven org.jenkins-ci.plugins:cloudbees-bitbucket-branch-source >=726.v7e6f53de133c =720.vbe985dd73d66 =2.9.8 =0 <2.9.7.2)

Commands are suggestions: review each one before running it.

Loading voting…