OS command execution vulnerability in Jenkins Docker Commons Plugin
CVE-2022-20617GHSA-jpxj-vgq5-prjc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins:docker-commons 1.18), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jenkins-ci.plugins:docker-commons
- Affected
- < 1.18
- Fixed in
- 1.18
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jpxj-vgq5-prjc lists affected ranges: Maven org.jenkins-ci.plugins:docker-commons >=0 <1.18
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-20617: 2.26% estimated exploitation activity in the next 30 days; percentile 82.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Jenkins Docker Commons Plugin 1.17 and earlier does not sanitize the name of an image or a tag, resulting in an OS command execution vulnerability exploitable by attackers with Item/Configure permission or able to control the contents of a previously configured job's SCM repository.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jpxj-vgq5-prjc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-20617 Advisory: OS command execution vulnerability in Jenkins Docker Commons Plugin IDs: CVE-2022-20617, GHSA-jpxj-vgq5-prjc Record: https://patchnext.com/advisories/cve-2022-20617 (revision 1, source checked 26 Oct 2026, 16:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins:docker-commons 1.18. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jenkins-ci.plugins:docker-commons: affected < 1.18; fixed in 1.18 ## Suggested inspection (read-only) - Maven org.jenkins-ci.plugins:docker-commons: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jenkins-ci.plugins:docker-commons. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jpxj-vgq5-prjc (GitHub-reviewed advisory GHSA-jpxj-vgq5-prjc lists affected ranges: Maven org.jenkins-ci.plugins:docker-commons >=0 <1.18) Commands are suggestions: review each one before running it.
Loading voting…