Skip to content

← Actionable
High, CVSS 7.5amended

protobuf-cpp and protobuf-python have potential Denial of Service issue

CVE-2022-1941GHSA-8gq9-2x98-w8hf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (protobuf 4.21.6, 3.20.2, 3.19.5, 3.18.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI protobuf

    Affected
    < 3.18.3>= 3.19.0, < 3.19.5>= 3.20.0, < 3.20.2>= 4.0.0, < 4.21.6
    Fixed in
    4.21.6, 3.20.2, 3.18.3, 3.19.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-1941: 1.51% estimated exploitation activity in the next 30 days; percentile 74.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A message parsing and memory management vulnerability in ProtocolBuffer’s C++ and Python implementations can trigger an out of memory (OOM) failure when processing a specially crafted message, which could lead to a denial of service (DoS) on services using the libraries. Reporter: ClusterFuzz Affected versions: All versions of C++ Protobufs (including Python) prior to the versions listed below. Severity & Impact As scored by google Medium 5.7 - CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H Asscored byt NIST High 7.5 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H A small (~500 KB) malicious payload can be constructed which causes the running service to allocate more than 3GB of RAM. Proof of Concept For reproduction details, please refer to the unit test that identifies the specific inputs that exercise this parsing weakness. Mitigation / Patching Please update to the latest available versions of the following packages: - protobuf-cpp (3.18.3, 3.19.5, 3.20.2, 3.21.6) -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8gq9-2x98-w8hf

  2. Revision 1 · created ·

    Published from osv record GHSA-8gq9-2x98-w8hf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-1941

Advisory: protobuf-cpp and protobuf-python have potential Denial of Service issue
IDs: CVE-2022-1941, GHSA-8gq9-2x98-w8hf
Record: https://patchnext.com/advisories/cve-2022-1941 (revision 2, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: protobuf 4.21.6, 3.20.2, 3.19.5, 3.18.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI protobuf: affected < 3.18.3; >= 3.19.0, < 3.19.5; >= 3.20.0, < 3.20.2; >= 4.0.0, < 4.21.6; fixed in 4.21.6, 3.20.2, 3.18.3, 3.19.5

## Suggested inspection (read-only)
- `python -m pip show protobuf`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on protobuf.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8gq9-2x98-w8hf (OSV record GHSA-8gq9-2x98-w8hf lists affected ranges: PyPI protobuf >=0 =3.19.0 =3.20.0 =4.0.0 <4.21.6 (fixed))
- Verified: https://github.com/advisories/GHSA-8gq9-2x98-w8hf (GitHub-reviewed advisory GHSA-8gq9-2x98-w8hf lists affected ranges: PyPI protobuf >=0 =3.19.0 =3.20.0 =4.0.0 <4.21.6)

Commands are suggestions: review each one before running it.

Loading voting…