Skip to content

← Actionable
Medium, CVSS 6.8amended

Cross-site Scripting in bootstrap-table

CVE-2022-1726GHSA-grw5-g9h2-wpg8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (bootstrap-table 1.20.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:L
EPSS
  • CVE-2022-1726: 0.89% estimated exploitation activity in the next 30 days; percentile 59.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Bootstrap Tables XSS vulnerability with Table Export plug-in when exportOptions: htmlContent is true in GitHub repository wenzhixin/bootstrap-table prior to 1.20.2. Disclosing session cookies, disclosing secure session data, exfiltrating data to third-parties.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-grw5-g9h2-wpg8

  2. Revision 1 · created ·

    Published from osv record GHSA-grw5-g9h2-wpg8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-1726

Advisory: Cross-site Scripting in bootstrap-table
IDs: CVE-2022-1726, GHSA-grw5-g9h2-wpg8
Record: https://patchnext.com/advisories/cve-2022-1726 (revision 2, source checked 26 Oct 2026, 12:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: bootstrap-table 1.20.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm bootstrap-table: affected < 1.20.2; fixed in 1.20.2

## Suggested inspection (read-only)
- `npm ls bootstrap-table --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on bootstrap-table.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-grw5-g9h2-wpg8 (OSV record GHSA-grw5-g9h2-wpg8 lists affected ranges: npm bootstrap-table >=0 <1.20.2 (fixed))
- Verified: https://github.com/advisories/GHSA-grw5-g9h2-wpg8 (GitHub-reviewed advisory GHSA-grw5-g9h2-wpg8 lists affected ranges: npm bootstrap-table >=0 <1.20.2)

Commands are suggestions: review each one before running it.

Loading voting…