Server-Side Request Forgery in scout-browser
CVE-2022-1592GHSA-g53g-q539-93cv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (scout-browser 4.52), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI scout-browser
- Affected
- < 4.52
- Fixed in
- 4.52
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g53g-q539-93cv lists affected ranges: PyPI scout-browser >=0 <4.52 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g53g-q539-93cv lists affected ranges: PyPI scout-browser >=0 <4.52
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
- EPSS
- CVE-2022-1592: 1.33% estimated exploitation activity in the next 30 days; percentile 71.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Pypi package scout-browser (GitHub repository clinical-genomics/scout) prior to v4.52 is vulnerable to server-side request forgery. An attacker could make the application perform arbitrary requests to steal cookies, request access to private areas, or lead to cross-site scripting.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-g53g-q539-93cv
- Revision 1 · created ·
Published from osv record GHSA-g53g-q539-93cv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-1592 Advisory: Server-Side Request Forgery in scout-browser IDs: CVE-2022-1592, GHSA-g53g-q539-93cv Record: https://patchnext.com/advisories/cve-2022-1592 (revision 2, source checked 26 Oct 2026, 13:11 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: scout-browser 4.52. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI scout-browser: affected < 4.52; fixed in 4.52 ## Suggested inspection (read-only) - `python -m pip show scout-browser`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on scout-browser. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-g53g-q539-93cv (OSV record GHSA-g53g-q539-93cv lists affected ranges: PyPI scout-browser >=0 <4.52 (fixed)) - Verified: https://github.com/advisories/GHSA-g53g-q539-93cv (GitHub-reviewed advisory GHSA-g53g-q539-93cv lists affected ranges: PyPI scout-browser >=0 <4.52) Commands are suggestions: review each one before running it.
Loading voting…