Skip to content

← Actionable
Medium, CVSS 6.8amended

Path Traversal in scout-browser

CVE-2022-1554GHSA-694v-63fq-fmr4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (scout-browser 4.52), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:H/A:L
EPSS
  • CVE-2022-1554: 1.37% estimated exploitation activity in the next 30 days; percentile 71.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Scout is a Variant Call Format (VCF) visualization interface. The Pypi package scout-browser is vulnerable to path traversal due to sendfile call in versions prior to 4.52.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-694v-63fq-fmr4

  2. Revision 1 · created ·

    Published from osv record GHSA-694v-63fq-fmr4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-1554

Advisory: Path Traversal in scout-browser
IDs: CVE-2022-1554, GHSA-694v-63fq-fmr4
Record: https://patchnext.com/advisories/cve-2022-1554 (revision 2, source checked 26 Oct 2026, 13:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: scout-browser 4.52. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI scout-browser: affected < 4.52; fixed in 4.52

## Suggested inspection (read-only)
- `python -m pip show scout-browser`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on scout-browser.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-694v-63fq-fmr4 (OSV record GHSA-694v-63fq-fmr4 lists affected ranges: PyPI scout-browser >=0 <4.52 (fixed))
- Verified: https://github.com/advisories/GHSA-694v-63fq-fmr4 (GitHub-reviewed advisory GHSA-694v-63fq-fmr4 lists affected ranges: PyPI scout-browser >=0 <4.52)

Commands are suggestions: review each one before running it.

Loading voting…