Resource leakage when decoding certificates and keys
CVE-2022-1473GHSA-g323-fr93-4j3c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openssl-src 300.0.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io openssl-src
- Affected
- >= 300.0.0, < 300.0.6
- Fixed in
- 300.0.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g323-fr93-4j3c lists affected ranges: crates.io openssl-src >=300.0.0 <300.0.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2022-1473: 4.68% estimated exploitation activity in the next 30 days; percentile 91.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The OPENSSLLHflush() function, which empties a hash table, contains a bug that breaks reuse of the memory occuppied by the removed hash table entries. This function is used when decoding certificates or keys. If a long lived process periodically decodes certificates or keys its memory usage will expand without bounds and the process might be terminated by the operating system causing a denial of service. Also traversing the empty hash table entries will take increasingly more time. Typically such long lived processes might be TLS clients or TLS servers configured to accept client certificate authentication. The function was added in the OpenSSL 3.0 version thus older releases are not affected by the issue. Fixed in OpenSSL 3.0.3 (Affected 3.0.0,3.0.1,3.0.2).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g323-fr93-4j3c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-1473 Advisory: Resource leakage when decoding certificates and keys IDs: CVE-2022-1473, GHSA-g323-fr93-4j3c Record: https://patchnext.com/advisories/cve-2022-1473 (revision 1, source checked 26 Oct 2026, 15:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openssl-src 300.0.6. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io openssl-src: affected >= 300.0.0, < 300.0.6; fixed in 300.0.6 ## Suggested inspection (read-only) - crates.io openssl-src: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openssl-src. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g323-fr93-4j3c (GitHub-reviewed advisory GHSA-g323-fr93-4j3c lists affected ranges: crates.io openssl-src >=300.0.0 <300.0.6) Commands are suggestions: review each one before running it.
Loading voting…