Cross site scripting in facturascripts
CVE-2022-1457GHSA-8wp2-vxpg-xcvp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (neorazorx/facturascripts 2022.04), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist neorazorx/facturascripts
- Affected
- < 2022.04
- Fixed in
- 2022.04
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8wp2-vxpg-xcvp lists affected ranges: Packagist neorazorx/facturascripts >=0 <2022.04
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.0 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2022-1457: 0.75% estimated exploitation activity in the next 30 days; percentile 55.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
facturasripts is an open source ERP software. Store XSS in title parameter executing at EditUser Page & EditProducto page in GitHub repository neorazorx/facturascripts prior to 2022.04. Cross-site scripting attacks can have devastating consequences. Code injected into a vulnerable application can exfiltrate data or install malware on the user's machine. Attackers can masquerade as authorized users via session cookies, allowing them to perform any action allowed by the user account.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8wp2-vxpg-xcvp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-1457 Advisory: Cross site scripting in facturascripts IDs: CVE-2022-1457, GHSA-8wp2-vxpg-xcvp Record: https://patchnext.com/advisories/cve-2022-1457 (revision 1, source checked 26 Oct 2026, 13:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: neorazorx/facturascripts 2022.04. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist neorazorx/facturascripts: affected < 2022.04; fixed in 2022.04 ## Suggested inspection (read-only) - Packagist neorazorx/facturascripts: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on neorazorx/facturascripts. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8wp2-vxpg-xcvp (GitHub-reviewed advisory GHSA-8wp2-vxpg-xcvp lists affected ranges: Packagist neorazorx/facturascripts >=0 <2022.04) Commands are suggestions: review each one before running it.
Loading voting…