Cross-site Scripting in snipe-it
CVE-2022-1380GHSA-p885-prv3-m4xv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (snipe/snipe-it 5.4.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist snipe/snipe-it
- Affected
- < 5.4.3
- Fixed in
- 5.4.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p885-prv3-m4xv lists affected ranges: Packagist snipe/snipe-it >=0 <5.4.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2022-1380: 0.85% estimated exploitation activity in the next 30 days; percentile 58.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Stored Cross Site Scripting vulnerability in Item name parameter in GitHub repository snipe/snipe-it prior to v5.4.3. The vulnerability is capable of stolen the user Cookie.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-p885-prv3-m4xv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-1380 Advisory: Cross-site Scripting in snipe-it IDs: CVE-2022-1380, GHSA-p885-prv3-m4xv Record: https://patchnext.com/advisories/cve-2022-1380 (revision 1, source checked 26 Oct 2026, 13:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: snipe/snipe-it 5.4.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist snipe/snipe-it: affected < 5.4.3; fixed in 5.4.3 ## Suggested inspection (read-only) - Packagist snipe/snipe-it: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on snipe/snipe-it. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p885-prv3-m4xv (GitHub-reviewed advisory GHSA-p885-prv3-m4xv lists affected ranges: Packagist snipe/snipe-it >=0 <5.4.3) Commands are suggestions: review each one before running it.
Loading voting…