Old sessions not blocked by login enable function in Snipe-IT
CVE-2022-1155GHSA-636j-7x7r-gvw2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (snipe/snipe-it 6.0.0-RC-6, 5.4.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist snipe/snipe-it
- Affected
- >= 6.0.0-RC-1, <= 6.0.0-RC-5< 5.4.2
- Fixed in
- 5.4.2, 6.0.0-RC-6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-636j-7x7r-gvw2 lists affected ranges: Packagist snipe/snipe-it >=6.0.0-RC-1 =0 <5.4.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.4 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
- EPSS
- CVE-2022-1155: 0.99% estimated exploitation activity in the next 30 days; percentile 62.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Snipe-IT is a FOSS project for asset management in IT Operations. In Snipe-IT versions 5.4.1 and 6.0.0-RC-5 and prior, active sessions are not revoked when a user account is disabled, allowing that user to still access information that they should no longer be able to. Workarounds include using the KillAllSessions console command, clearing the contents of the storage/framework/sessions directory, or changing the cookie name, but all of those options logout ALL users, which could be kind of annoying. This issue is fixed in versions 6.0.0-RC-6 and 5.4.2.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-636j-7x7r-gvw2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-1155 Advisory: Old sessions not blocked by login enable function in Snipe-IT IDs: CVE-2022-1155, GHSA-636j-7x7r-gvw2 Record: https://patchnext.com/advisories/cve-2022-1155 (revision 1, source checked 26 Oct 2026, 13:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: snipe/snipe-it 6.0.0-RC-6, 5.4.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist snipe/snipe-it: affected >= 6.0.0-RC-1, <= 6.0.0-RC-5; < 5.4.2; fixed in 5.4.2, 6.0.0-RC-6 ## Suggested inspection (read-only) - Packagist snipe/snipe-it: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on snipe/snipe-it. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-636j-7x7r-gvw2 (GitHub-reviewed advisory GHSA-636j-7x7r-gvw2 lists affected ranges: Packagist snipe/snipe-it >=6.0.0-RC-1 =0 <5.4.2) Commands are suggestions: review each one before running it.
Loading voting…