Cross site scripting in safe-svg
CVE-2022-1091GHSA-5h7w-hmxc-99g5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (darylldoyle/safe-svg 1.9.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist darylldoyle/safe-svg
- Affected
- < 1.9.10
- Fixed in
- 1.9.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5h7w-hmxc-99g5 lists affected ranges: Packagist darylldoyle/safe-svg >=0 <1.9.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2022-1091: 1.20% estimated exploitation activity in the next 30 days; percentile 68.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The sanitisation step of the Safe SVG WordPress plugin before 1.9.10 can be bypassed by spoofing the content-type in the POST request to upload a file. Exploiting this vulnerability, an attacker will be able to perform the kinds of attacks that this plugin should prevent (mainly XSS, but depending on further use of uploaded SVG files potentially other XML attacks).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5h7w-hmxc-99g5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-1091 Advisory: Cross site scripting in safe-svg IDs: CVE-2022-1091, GHSA-5h7w-hmxc-99g5 Record: https://patchnext.com/advisories/cve-2022-1091 (revision 1, source checked 26 Oct 2026, 14:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: darylldoyle/safe-svg 1.9.10. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist darylldoyle/safe-svg: affected < 1.9.10; fixed in 1.9.10 ## Suggested inspection (read-only) - Packagist darylldoyle/safe-svg: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on darylldoyle/safe-svg. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5h7w-hmxc-99g5 (GitHub-reviewed advisory GHSA-5h7w-hmxc-99g5 lists affected ranges: Packagist darylldoyle/safe-svg >=0 <1.9.10) Commands are suggestions: review each one before running it.
Loading voting…