Tenant and Verifier might not use the same registrar data
CVE-2022-1053GHSA-jf66-3q76-h5p5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (keylime 6.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI keylime
- Affected
- < 6.4.0
- Fixed in
- 6.4.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jf66-3q76-h5p5 lists affected ranges: PyPI keylime >=0 <6.4.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jf66-3q76-h5p5 lists affected ranges: PyPI keylime >=0 <6.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2022-1053: 1.48% estimated exploitation activity in the next 30 days; percentile 73.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Keylime does not enforce that the agent registrar data is the same when the tenant uses it for validation of the EK and identity quote and the verifier for validating the integrity quote. This allows an attacker to use one AK, EK pair from a real TPM to pass EK validation and give the verifier an AK of a software TPM. A successful attack breaks the entire chain of trust because a not validated AK is used by the verifier. This issue is worse if the validation happens first and then the agent gets added to the verifier because the timing is easier and the verifier does not validate the regcount entry being equal to 1. At this time, there are no known workaround.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-jf66-3q76-h5p5
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-jf66-3q76-h5p5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-1053 Advisory: Tenant and Verifier might not use the same registrar data IDs: CVE-2022-1053, GHSA-jf66-3q76-h5p5 Record: https://patchnext.com/advisories/cve-2022-1053 (revision 3, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: keylime 6.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI keylime: affected < 6.4.0; fixed in 6.4.0 ## Suggested inspection (read-only) - `python -m pip show keylime`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on keylime. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jf66-3q76-h5p5 (OSV record GHSA-jf66-3q76-h5p5 lists affected ranges: PyPI keylime >=0 <6.4.0 (fixed)) - Verified: https://github.com/advisories/GHSA-jf66-3q76-h5p5 (GitHub-reviewed advisory GHSA-jf66-3q76-h5p5 lists affected ranges: PyPI keylime >=0 <6.4.0) Commands are suggestions: review each one before running it.
Loading voting…