Stored Cross-site Scripting in Microweber
CVE-2022-0954GHSA-8c76-mxv5-w4g8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (microweber/microweber 1.2.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist microweber/microweber
- Affected
- <= 1.2.11
- Fixed in
- 1.2.12
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8c76-mxv5-w4g8 lists affected ranges: Packagist microweber/microweber >=0 <=1.2.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-0954: 3.20% estimated exploitation activity in the next 30 days; percentile 88.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Microweber 1.2.11 and prior contains multiple stored cross-site scripting vulnerabilities in Shop's Other Settings, Shop's Autorespond E-mail Settings and Shops' Payments Methods.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8c76-mxv5-w4g8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-0954 Advisory: Stored Cross-site Scripting in Microweber IDs: CVE-2022-0954, GHSA-8c76-mxv5-w4g8 Record: https://patchnext.com/advisories/cve-2022-0954 (revision 1, source checked 26 Oct 2026, 13:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: microweber/microweber 1.2.12. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist microweber/microweber: affected <= 1.2.11; fixed in 1.2.12 ## Suggested inspection (read-only) - Packagist microweber/microweber: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on microweber/microweber. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8c76-mxv5-w4g8 (GitHub-reviewed advisory GHSA-8c76-mxv5-w4g8 lists affected ranges: Packagist microweber/microweber >=0 <=1.2.11) Commands are suggestions: review each one before running it.
Loading voting…