Cross-site Scripting in ShowDoc
CVE-2022-0941GHSA-wg4r-q74r-p7c8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (showdoc/showdoc 2.10.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist showdoc/showdoc
- Affected
- <= 2.10.3
- Fixed in
- 2.10.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wg4r-q74r-p7c8 lists affected ranges: Packagist showdoc/showdoc >=0 <=2.10.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2022-0941: 0.62% estimated exploitation activity in the next 30 days; percentile 49.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
ShowDoc is vulnerable to stored cross-site scripting due to unrestricted file upload in versions 2.10.3 and prior. A patch is available and anticipated to be part of version 2.10.4.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wg4r-q74r-p7c8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-0941 Advisory: Cross-site Scripting in ShowDoc IDs: CVE-2022-0941, GHSA-wg4r-q74r-p7c8 Record: https://patchnext.com/advisories/cve-2022-0941 (revision 1, source checked 26 Oct 2026, 13:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: showdoc/showdoc 2.10.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist showdoc/showdoc: affected <= 2.10.3; fixed in 2.10.4 ## Suggested inspection (read-only) - Packagist showdoc/showdoc: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on showdoc/showdoc. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wg4r-q74r-p7c8 (GitHub-reviewed advisory GHSA-wg4r-q74r-p7c8 lists affected ranges: Packagist showdoc/showdoc >=0 <=2.10.3) Commands are suggestions: review each one before running it.
Loading voting…