Improper Authorization in cobbler
CVE-2022-0860GHSA-mcg6-h362-cmq5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (cobbler 3.3.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI cobbler
- Affected
- < 3.3.2
- Fixed in
- 3.3.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mcg6-h362-cmq5 lists affected ranges: PyPI cobbler >=0 <3.3.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mcg6-h362-cmq5 lists affected ranges: PyPI cobbler >=0 <3.3.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2022-0860: 2.26% estimated exploitation activity in the next 30 days; percentile 82.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact If PAM is correctly configured and a user account is set to expired, the expired user-account is still able to successfully log into Cobbler in all places (Web UI, CLI & XMLRPC-API). The same applies to user accounts with passwords set to be expired. Patches There is a patch for the latest Cobbler 3.3.2 available, however a backport will be done for 3.2.x. Workarounds - Delete expired accounts which are able to access Cobbler via PAM. - Use chage -l <username to lock the account. If the account has SSH-Keys attached then remove them completely. References - Originally discovered by @ysf at https://www.huntr.dev/bounties/c458b868-63df-414e-af10-47e3745caa1d/ How to test if my Cobbler instance is affected? The following pytest test assumes that your PAM setup is correct. In case the added user is not able to login, this test does not make sense to be executed. For more information If you have any questions or comments about this advisory: Open an issue in the Cobbler repository…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-mcg6-h362-cmq5
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-mcg6-h362-cmq5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-0860 Advisory: Improper Authorization in cobbler IDs: CVE-2022-0860, GHSA-mcg6-h362-cmq5 Record: https://patchnext.com/advisories/cve-2022-0860 (revision 3, source checked 26 Oct 2026, 13:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: cobbler 3.3.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI cobbler: affected < 3.3.2; fixed in 3.3.2 ## Suggested inspection (read-only) - `python -m pip show cobbler`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on cobbler. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mcg6-h362-cmq5 (OSV record GHSA-mcg6-h362-cmq5 lists affected ranges: PyPI cobbler >=0 <3.3.2 (fixed)) - Verified: https://github.com/advisories/GHSA-mcg6-h362-cmq5 (GitHub-reviewed advisory GHSA-mcg6-h362-cmq5 lists affected ranges: PyPI cobbler >=0 <3.3.2) Commands are suggestions: review each one before running it.
Loading voting…