Skip to content

← Actionable
High, CVSS 8.8

Code injection in dolibarr/dolibarr

CVE-2022-0819GHSA-42qm-c3cf-9wv2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (dolibarr/dolibarr 15.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-0819: 42.68% estimated exploitation activity in the next 30 days; percentile 98.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Improper php function sanitization, lead to an ability to inject arbitrary PHP code and run arbitrary commands on file system. In the function "doleval" in file "dolibarr/htdocs/core/lib/functions.lib.php" dangerous PHP functions are sanitized using "strreplace" and can be bypassed using following code in $s parameter

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-42qm-c3cf-9wv2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-0819

Advisory: Code injection in dolibarr/dolibarr
IDs: CVE-2022-0819, GHSA-42qm-c3cf-9wv2
Record: https://patchnext.com/advisories/cve-2022-0819 (revision 1, source checked 26 Oct 2026, 14:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dolibarr/dolibarr 15.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist dolibarr/dolibarr: affected < 15.0.1; fixed in 15.0.1

## Suggested inspection (read-only)
- Packagist dolibarr/dolibarr: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dolibarr/dolibarr.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-42qm-c3cf-9wv2 (GitHub-reviewed advisory GHSA-42qm-c3cf-9wv2 lists affected ranges: Packagist dolibarr/dolibarr >=0 <15.0.1)

Commands are suggestions: review each one before running it.

Loading voting…