Skip to content

← Actionable
Medium, CVSS 6.5amended

url-parse incorrectly parses hostname / protocol due to unstripped leading control characters.

CVE-2022-0691GHSA-jf5r-8hm2-f872

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (url-parse 1.5.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm url-parse

    Affected
    >= 0.1.0, < 1.5.9
    Fixed in
    1.5.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2022-0691: 2.22% estimated exploitation activity in the next 30 days; percentile 82.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Leading control characters in a URL are not stripped when passed into url-parse. This can cause input URLs to be mistakenly be interpreted as a relative URL without a hostname and protocol, while the WHATWG URL parser will trim control characters and treat it as an absolute URL. If url-parse is used in security decisions involving the hostname / protocol, and the input URL is used in a client which uses the WHATWG URL parser, the decision may be incorrect. This can also lead to a cross-site scripting (XSS) vulnerability if url-parse is used to check for the javascript: protocol in URLs. See following example:

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-jf5r-8hm2-f872

  2. Revision 1 · created ·

    Published from osv record GHSA-jf5r-8hm2-f872

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-0691

Advisory: url-parse incorrectly parses hostname / protocol due to unstripped leading control characters.
IDs: CVE-2022-0691, GHSA-jf5r-8hm2-f872
Record: https://patchnext.com/advisories/cve-2022-0691 (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: url-parse 1.5.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm url-parse: affected >= 0.1.0, < 1.5.9; fixed in 1.5.9

## Suggested inspection (read-only)
- `npm ls url-parse --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on url-parse.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jf5r-8hm2-f872 (OSV record GHSA-jf5r-8hm2-f872 lists affected ranges: npm url-parse >=0.1.0 <1.5.9 (fixed))
- Verified: https://github.com/advisories/GHSA-jf5r-8hm2-f872 (GitHub-reviewed advisory GHSA-jf5r-8hm2-f872 lists affected ranges: npm url-parse >=0.1.0 <1.5.9)

Commands are suggestions: review each one before running it.

Loading voting…