Authorization Bypass Through User-Controlled Key in url-parse
CVE-2022-0686GHSA-hgjh-723h-mx2j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (url-parse 1.5.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm url-parse
- Affected
- < 1.5.8
- Fixed in
- 1.5.8
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hgjh-723h-mx2j lists affected ranges: npm url-parse >=0 <1.5.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hgjh-723h-mx2j lists affected ranges: npm url-parse >=0 <1.5.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2022-0686: 1.83% estimated exploitation activity in the next 30 days; percentile 78.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
url-parse prior to version 1.5.8 is vulnerable to Authorization Bypass Through User-Controlled Key.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hgjh-723h-mx2j
- Revision 1 · created ·
Published from osv record GHSA-hgjh-723h-mx2j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-0686 Advisory: Authorization Bypass Through User-Controlled Key in url-parse IDs: CVE-2022-0686, GHSA-hgjh-723h-mx2j Record: https://patchnext.com/advisories/cve-2022-0686 (revision 2, source checked 26 Oct 2026, 12:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: url-parse 1.5.8. A vendor fix does not mean a deployment is fixed. ## Affected components - npm url-parse: affected < 1.5.8; fixed in 1.5.8 ## Suggested inspection (read-only) - `npm ls url-parse --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on url-parse. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hgjh-723h-mx2j (OSV record GHSA-hgjh-723h-mx2j lists affected ranges: npm url-parse >=0 <1.5.8 (fixed)) - Verified: https://github.com/advisories/GHSA-hgjh-723h-mx2j (GitHub-reviewed advisory GHSA-hgjh-723h-mx2j lists affected ranges: npm url-parse >=0 <1.5.8) Commands are suggestions: review each one before running it.
Loading voting…