Skip to content

← Actionable
Medium, CVSS 6.5amended

url-parse Incorrectly parses URLs that include an '@'

CVE-2022-0639GHSA-8v38-pw62-9cw2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (url-parse 1.5.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm url-parse

    Affected
    >= 1.0.0, < 1.5.7
    Fixed in
    1.5.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2022-0639: 1.54% estimated exploitation activity in the next 30 days; percentile 74.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A specially crafted URL with an '@' sign but empty user info and no hostname, when parsed with url-parse, url-parse will return the incorrect href. In particular, Will return: If the 'hostname' or 'origin' attributes of the output from url-parse are used in security decisions and the final 'href' attribute of the output is then used to make a request, the decision may be incorrect.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8v38-pw62-9cw2

  2. Revision 1 · created ·

    Published from osv record GHSA-8v38-pw62-9cw2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-0639

Advisory: url-parse Incorrectly parses URLs that include an '@'
IDs: CVE-2022-0639, GHSA-8v38-pw62-9cw2
Record: https://patchnext.com/advisories/cve-2022-0639 (revision 2, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: url-parse 1.5.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm url-parse: affected >= 1.0.0, < 1.5.7; fixed in 1.5.7

## Suggested inspection (read-only)
- `npm ls url-parse --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on url-parse.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8v38-pw62-9cw2 (OSV record GHSA-8v38-pw62-9cw2 lists affected ranges: npm url-parse >=1.0.0 <1.5.7 (fixed))
- Verified: https://github.com/advisories/GHSA-8v38-pw62-9cw2 (GitHub-reviewed advisory GHSA-8v38-pw62-9cw2 lists affected ranges: npm url-parse >=1.0.0 <1.5.7)

Commands are suggestions: review each one before running it.

Loading voting…