Skip to content

← Actionable
Medium, CVSS 6.1amended

open redirect in pollbot

CVE-2022-0637GHSA-vg27-hr3v-3cqv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pollbot 1.4.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pollbot

    Affected
    < 1.4.6
    Fixed in
    1.4.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2022-0637: 0.43% estimated exploitation activity in the next 30 days; percentile 37.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

(From https://bugzilla.mozilla.org/showbug.cgi?id=1753838) Summary: There was an open redirection vulnerability in the path of: https://pollbot.services.mozilla.com/ and https://pollbot.stage.mozaws.net/ Description: An attacker can redirect anyone to malicious sites. Steps To Reproduce: Type in this URL: https://pollbot.services.mozilla.com/%0a/evil.com/ It redirects to that website evil.com evil.com was used as an example but this could be any website. Note, the /%0a/ and trailing / are required. Supporting Material/References: https://cheatsheetseries.owasp.org/cheatsheets/UnvalidatedRedirectsandForwardsCheatSheet.html Impact Attackers can serve malicious websites that steal passwords or download ransomware to their victims machine due to a redirect and there are a heap of other attack vectors.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vg27-hr3v-3cqv

  2. Revision 1 · created ·

    Published from osv record GHSA-vg27-hr3v-3cqv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-0637

Advisory: open redirect in pollbot
IDs: CVE-2022-0637, GHSA-vg27-hr3v-3cqv
Record: https://patchnext.com/advisories/cve-2022-0637 (revision 2, source checked 26 Oct 2026, 13:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pollbot 1.4.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pollbot: affected < 1.4.6; fixed in 1.4.6

## Suggested inspection (read-only)
- `python -m pip show pollbot`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pollbot.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vg27-hr3v-3cqv (OSV record GHSA-vg27-hr3v-3cqv lists affected ranges: PyPI pollbot >=0 <1.4.6 (fixed))
- Verified: https://github.com/advisories/GHSA-vg27-hr3v-3cqv (GitHub-reviewed advisory GHSA-vg27-hr3v-3cqv lists affected ranges: PyPI pollbot >=0 <1.4.6)

Commands are suggestions: review each one before running it.

Loading voting…