Skip to content

← Actionable
Medium, CVSS 6.5amended

Incorrect Authorization and Exposure of Sensitive Information to an Unauthorized Actor in scrapy

CVE-2022-0577GHSA-cjvr-mfj7-j4j8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (scrapy 2.6.0, 1.8.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI scrapy

    Affected
    < 1.8.2>= 2.0.0, < 2.6.0
    Fixed in
    2.6.0, 1.8.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2022-0577: 1.23% estimated exploitation activity in the next 30 days; percentile 68.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact If you manually define cookies on a Request object, and that Request object gets a redirect response, the new Request object scheduled to follow the redirect keeps those user-defined cookies, regardless of the target domain. Patches Upgrade to Scrapy 2.6.0, which resets cookies when creating Request objects to follow redirects¹, and drops the Cookie header if manually-defined if the redirect target URL domain name does not match the source URL domain name². If you are using Scrapy 1.8 or a lower version, and upgrading to Scrapy 2.6.0 is not an option, you may upgrade to Scrapy 1.8.2 instead. ¹ At that point the original, user-set cookies have been processed by the cookie middleware into the global or request-specific cookiejar, with their domain restricted to the domain of the original URL, so when the cookie middleware processes the new (redirect) request it will incorporate those cookies into the new request as long as the domain of the new request matches the domain of the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-cjvr-mfj7-j4j8

  2. Revision 1 · created ·

    Published from osv record GHSA-cjvr-mfj7-j4j8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-0577

Advisory: Incorrect Authorization and Exposure of Sensitive Information to an Unauthorized Actor in scrapy
IDs: CVE-2022-0577, GHSA-cjvr-mfj7-j4j8
Record: https://patchnext.com/advisories/cve-2022-0577 (revision 2, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: scrapy 2.6.0, 1.8.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI scrapy: affected < 1.8.2; >= 2.0.0, < 2.6.0; fixed in 2.6.0, 1.8.2

## Suggested inspection (read-only)
- `python -m pip show scrapy`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on scrapy.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cjvr-mfj7-j4j8 (OSV record GHSA-cjvr-mfj7-j4j8 lists affected ranges: PyPI scrapy >=0 =2.0.0 <2.6.0 (fixed))
- Verified: https://github.com/advisories/GHSA-cjvr-mfj7-j4j8 (GitHub-reviewed advisory GHSA-cjvr-mfj7-j4j8 lists affected ranges: PyPI scrapy >=0 =2.0.0 <2.6.0)

Commands are suggestions: review each one before running it.

Loading voting…