Skip to content

← Actionable
Critical, CVSS 9.8amended

Path Traversal in w-zip

CVE-2022-0401GHSA-fr6q-jv7j-35g3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (w-zip 1.0.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm w-zip

    Affected
    < 1.0.12
    Fixed in
    1.0.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-0401: 1.62% estimated exploitation activity in the next 30 days; percentile 76.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Path Traversal in NPM w-zip prior to 1.0.12.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fr6q-jv7j-35g3

  2. Revision 1 · created ·

    Published from osv record GHSA-fr6q-jv7j-35g3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-0401

Advisory: Path Traversal in w-zip
IDs: CVE-2022-0401, GHSA-fr6q-jv7j-35g3
Record: https://patchnext.com/advisories/cve-2022-0401 (revision 2, source checked 26 Oct 2026, 12:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: w-zip 1.0.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm w-zip: affected < 1.0.12; fixed in 1.0.12

## Suggested inspection (read-only)
- `npm ls w-zip --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on w-zip.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fr6q-jv7j-35g3 (OSV record GHSA-fr6q-jv7j-35g3 lists affected ranges: npm w-zip >=0 <1.0.12 (fixed))
- Verified: https://github.com/advisories/GHSA-fr6q-jv7j-35g3 (GitHub-reviewed advisory GHSA-fr6q-jv7j-35g3 lists affected ranges: npm w-zip >=0 <1.0.12)

Commands are suggestions: review each one before running it.

Loading voting…