Skip to content

← Actionable
High, CVSS 8.8

Mustache remote code injection vulnerability

CVE-2022-0323GHSA-4rmr-c2jx-vx27

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mustache/mustache 2.14.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-0323: 0.67% estimated exploitation activity in the next 30 days; percentile 52.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Mustache.php v2.0.0 through v2.14.0, Sections tag can lead to arbitrary php code execution even if strictcallables is true when section value is controllable.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4rmr-c2jx-vx27

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-0323

Advisory: Mustache remote code injection vulnerability
IDs: CVE-2022-0323, GHSA-4rmr-c2jx-vx27
Record: https://patchnext.com/advisories/cve-2022-0323 (revision 1, source checked 26 Oct 2026, 14:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mustache/mustache 2.14.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist mustache/mustache: affected >= 2.0.0, < 2.14.1; fixed in 2.14.1

## Suggested inspection (read-only)
- Packagist mustache/mustache: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mustache/mustache.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4rmr-c2jx-vx27 (GitHub-reviewed advisory GHSA-4rmr-c2jx-vx27 lists affected ranges: Packagist mustache/mustache >=2.0.0 <2.14.1)

Commands are suggestions: review each one before running it.

Loading voting…