Skip to content

← Actionable
High, CVSS 8.8amended

node-fetch forwards secure headers to untrusted sites

CVE-2022-0235GHSA-r683-j2x4-v87g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (node-fetch 3.1.1, 2.6.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm node-fetch

    Affected
    >= 3.0.0, < 3.1.1< 2.6.7
    Fixed in
    3.1.1, 2.6.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-0235: 1.65% estimated exploitation activity in the next 30 days; percentile 76.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

node-fetch forwards secure headers such as authorization, www-authenticate, cookie, & cookie2 when redirecting to a untrusted site.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-r683-j2x4-v87g

  2. Revision 1 · created ·

    Published from osv record GHSA-r683-j2x4-v87g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-0235

Advisory: node-fetch forwards secure headers to untrusted sites
IDs: CVE-2022-0235, GHSA-r683-j2x4-v87g
Record: https://patchnext.com/advisories/cve-2022-0235 (revision 2, source checked 26 Oct 2026, 12:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: node-fetch 3.1.1, 2.6.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm node-fetch: affected >= 3.0.0, < 3.1.1; < 2.6.7; fixed in 3.1.1, 2.6.7

## Suggested inspection (read-only)
- `npm ls node-fetch --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on node-fetch.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r683-j2x4-v87g (OSV record GHSA-r683-j2x4-v87g lists affected ranges: npm node-fetch >=3.0.0 =0 <2.6.7 (fixed))
- Verified: https://github.com/advisories/GHSA-r683-j2x4-v87g (GitHub-reviewed advisory GHSA-r683-j2x4-v87g lists affected ranges: npm node-fetch >=3.0.0 =0 <2.6.7)

Commands are suggestions: review each one before running it.

Loading voting…