Cross-site Scripting in Fork CMS
CVE-2022-0145GHSA-qf2g-q4mc-w7rr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (forkcms/forkcms 5.11.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist forkcms/forkcms
- Affected
- < 5.11.1
- Fixed in
- 5.11.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qf2g-q4mc-w7rr lists affected ranges: Packagist forkcms/forkcms >=0 <5.11.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2022-0145: 0.68% estimated exploitation activity in the next 30 days; percentile 52.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Fork CMS prior to 5.11.1 is vulnerable to stored cross-site scripting. When uploading a new module, the description of the module can contain JavaScript code. The JavaScript code may be executed after uploading the new module and looking at the Details page.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qf2g-q4mc-w7rr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-0145 Advisory: Cross-site Scripting in Fork CMS IDs: CVE-2022-0145, GHSA-qf2g-q4mc-w7rr Record: https://patchnext.com/advisories/cve-2022-0145 (revision 1, source checked 26 Oct 2026, 13:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: forkcms/forkcms 5.11.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist forkcms/forkcms: affected < 5.11.1; fixed in 5.11.1 ## Suggested inspection (read-only) - Packagist forkcms/forkcms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on forkcms/forkcms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qf2g-q4mc-w7rr (GitHub-reviewed advisory GHSA-qf2g-q4mc-w7rr lists affected ranges: Packagist forkcms/forkcms >=0 <5.11.1) Commands are suggestions: review each one before running it.
Loading voting…