Skip to content

← Actionable
High, CVSS 7.1amended

Reflected cross-site scripting (XSS) vulnerability

CVE-2022-0087GHSA-hrgx-7j6v-xj82

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @keystone-next/auth

    Affected
    <= 37.0.0
    Fixed in
    no fixed version recorded
  • npm @keystone-6/auth

    Affected
    < 1.0.2
    Fixed in
    1.0.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
EPSS
  • CVE-2022-0087: 2.60% estimated exploitation activity in the next 30 days; percentile 85.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

This security advisory relates to a capability for an attacker to exploit a reflected cross-site scripting vulnerability when using the @keystone-6/auth package. Impact The vulnerability can impact users of the administration user interface when following an untrusted link to the signin or init page. This is a targeted attack and may present itself in the form of phishing and or chained in conjunction with some other vulnerability. Vulnerability mitigation Please upgrade to @keystone-6/auth = 1.0.2, where this vulnerability has been closed. If you are using @keystone-next/auth, we strongly recommend you upgrade to @keystone-6. Workarounds If for some reason you cannot upgrade the dependencies in software, you could alternatively - disable the administration user interface, or - if using a reverse-proxy, strip query parameters when accessing the administration interface References https://owasp.org/www-community/attacks/xss/ Thanks to Shivansh Khari (@Shivansh-Khari) for discovering…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hrgx-7j6v-xj82

  2. Revision 1 · created ·

    Published from osv record GHSA-hrgx-7j6v-xj82

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-0087

Advisory: Reflected cross-site scripting (XSS) vulnerability
IDs: CVE-2022-0087, GHSA-hrgx-7j6v-xj82
Record: https://patchnext.com/advisories/cve-2022-0087 (revision 2, source checked 26 Oct 2026, 12:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: @keystone-6/auth 1.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @keystone-next/auth: affected <= 37.0.0
- npm @keystone-6/auth: affected < 1.0.2; fixed in 1.0.2

## Suggested inspection (read-only)
- `npm ls @keystone-next/auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @keystone-6/auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @keystone-next/auth, @keystone-6/auth.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hrgx-7j6v-xj82 (OSV record GHSA-hrgx-7j6v-xj82 lists affected ranges: npm @keystone-6/auth >=0 =0 <=37.0.0)
- Verified: https://github.com/advisories/GHSA-hrgx-7j6v-xj82 (GitHub-reviewed advisory GHSA-hrgx-7j6v-xj82 lists affected ranges: npm @keystone-6/auth >=0 =0 <=37.0.0)

Commands are suggestions: review each one before running it.

Loading voting…