Server-Side Request Forgery in dompdf/dompdf
CVE-2022-0085GHSA-pf6p-25r2-fx45
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (dompdf/dompdf 2.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist dompdf/dompdf
- Affected
- < 2.0.0
- Fixed in
- 2.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pf6p-25r2-fx45 lists affected ranges: Packagist dompdf/dompdf >=0 <2.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2022-0085: 1.00% estimated exploitation activity in the next 30 days; percentile 62.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Server-Side Request Forgery (SSRF) in GitHub repository dompdf/dompdf prior to 2.0.0.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-pf6p-25r2-fx45
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-0085 Advisory: Server-Side Request Forgery in dompdf/dompdf IDs: CVE-2022-0085, GHSA-pf6p-25r2-fx45 Record: https://patchnext.com/advisories/cve-2022-0085 (revision 1, source checked 26 Oct 2026, 14:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: dompdf/dompdf 2.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist dompdf/dompdf: affected < 2.0.0; fixed in 2.0.0 ## Suggested inspection (read-only) - Packagist dompdf/dompdf: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on dompdf/dompdf. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-pf6p-25r2-fx45 (GitHub-reviewed advisory GHSA-pf6p-25r2-fx45 lists affected ranges: Packagist dompdf/dompdf >=0 <2.0.0) Commands are suggestions: review each one before running it.
Loading voting…