Skip to content

← Actionable
Unratedamended

VVE-2021-0002: Incorrect returndatasize when using simple forwarder proxies deployed prior to EIP-1167 adoption

CVE-2021-48019GHSA-375m-5fvv-xq23

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vyper 0.2.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vyper

    Affected
    < 0.2.9
    Fixed in
    0.2.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2021-48019: 0.25% estimated exploitation activity in the next 30 days; percentile 16.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Background @tjayrush reported a data handling issue with certain Web3 libraries using Vyper-deploy forwarder proxy contracts using our Vyper's built-in createforwarderto function prior to our change to support EIP-1167 style forwarder proxies. Impact If you are an end user of a forwarder-style proxy deployed using Vyper's built-in createforwarderto function AND you have a function that returns 4096 bytes AND you do no return data sanitation on the value returned, you could potentially see a data corruption issue. Otherwise, if you are handling the result of a return call AND you expect a specific RETURNDATASIZE that is less than 4096 (such as SafeERC20.safeTransfer) then the call will fail that check. Patches The issue was patched when we upgraded to EIP-1167 style forwarder proxies in #2281. Workarounds If you are making a call to a contract method that is expected to return <= 4096 bytes, there is no issue as the ABI decoders in both Solidity and Vyper will truncate the data…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-375m-5fvv-xq23

  2. Revision 1 · created ·

    Published from osv record GHSA-375m-5fvv-xq23

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-48019

Advisory: VVE-2021-0002: Incorrect `returndatasize` when using simple forwarder proxies deployed prior to EIP-1167 adoption
IDs: CVE-2021-48019, GHSA-375m-5fvv-xq23
Record: https://patchnext.com/advisories/cve-2021-48019 (revision 2, source checked 26 Oct 2026, 13:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vyper 0.2.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vyper: affected < 0.2.9; fixed in 0.2.9

## Suggested inspection (read-only)
- `python -m pip show vyper`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vyper.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-375m-5fvv-xq23 (OSV record GHSA-375m-5fvv-xq23 lists affected ranges: PyPI vyper >=0 <0.2.9 (fixed))
- Verified: https://github.com/advisories/GHSA-375m-5fvv-xq23 (GitHub-reviewed advisory GHSA-375m-5fvv-xq23 lists affected ranges: PyPI vyper >=0 <0.2.9)

Commands are suggestions: review each one before running it.

Loading voting…