Skip to content

← Actionable
High, CVSS 7.7amended

Incorrect version tags linked to external repository

CVE-2021-47986GHSA-593v-wcqx-hq2w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 4.10.0, 4.5.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm parse-server

    Affected
    >= 4.0.0, < 4.5.2>= 4.6.0, < 4.10.0
    Fixed in
    4.10.0, 4.5.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.7 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2021-47986: 0.18% estimated exploitation activity in the next 30 days; percentile 7.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
  • CVE-2021-47987: 0.18% estimated exploitation activity in the next 30 days; percentile 7.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A security incident caused a number of incorrect version tags to be pushed to the Parse Server repository. These version tags linked to a personal fork of a contributor who had write access to the repository. The code to which these tags linked has not been reviewed or approved by Parse Platform. Even though no releases were published with these incorrect versions, it was possible to define a Parse Server dependency that pointed to these version tags, for example if you defined this dependency: ```js "parse-server": "git@github.com:parse-community/parse-server.git#4.9.3" ``` We have since deleted the incorrect version tags, but they may still show up in your personal fork on GitHub or locally. We do not know when these tags have been pushed to the Parse Server repository, but we first became aware of this issue on July 21, 2021. We are not aware of any malicious code or concerns related to privacy, security or legality (e.g. proprietary code). However, it has been reported…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 5 · amended ·

    Amended from osv record GHSA-593v-wcqx-hq2w

  2. Revision 4 · amended ·

    Amended from ghsa record GHSA-593v-wcqx-hq2w

  3. Revision 3 · amended ·

    Amended from ghsa record GHSA-593v-wcqx-hq2w

  4. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  5. Revision 1 · created ·

    Published from osv record GHSA-593v-wcqx-hq2w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-47986

Advisory: Incorrect version tags linked to external repository
IDs: CVE-2021-47986, GHSA-593v-wcqx-hq2w
Record: https://patchnext.com/advisories/cve-2021-47986 (revision 5, source checked 3 Nov 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse-server 4.10.0, 4.5.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse-server: affected >= 4.0.0, < 4.5.2; >= 4.6.0, < 4.10.0; fixed in 4.10.0, 4.5.2

## Suggested inspection (read-only)
- `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-593v-wcqx-hq2w (OSV record GHSA-593v-wcqx-hq2w lists affected ranges: npm parse-server >=4.0.0 =4.6.0 <4.10.0 (fixed))
- Verified: https://github.com/advisories/GHSA-593v-wcqx-hq2w (GitHub-reviewed advisory GHSA-593v-wcqx-hq2w lists affected ranges: npm parse-server >=4.0.0 =4.6.0 <4.10.0)

Commands are suggestions: review each one before running it.

Loading voting…