ReDoS in LDAP schema parser
CVE-2021-46823GHSA-qfr5-wjpw-q4c4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (python-ldap 3.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI python-ldap
- Affected
- < 3.4.0
- Fixed in
- 3.4.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qfr5-wjpw-q4c4 lists affected ranges: PyPI python-ldap >=0 <3.4.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r8wq-qrxc-hmcm lists affected ranges: PyPI python-ldap >=0 <3.4.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r8wq-qrxc-hmcm lists affected ranges: PyPI python-ldap >=0 <3.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2021-46823: 1.94% estimated exploitation activity in the next 30 days; percentile 80.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
https://github.com/python-ldap/python-ldap/issues/424 Impact The LDAP schema parser of python-ldap 3.3.1 and earlier are vulnerable to a regular expression denial-of-service attack. The issue affects clients that use ldap.schema package to parse LDAP schema definitions from an untrusted source. Patches The upcoming release of python-ldap 3.4.0 will contain a workaround to prevent ReDoS attacks. The schema parser refuses schema definitions with an excessive amount of backslashes. Workarounds As a workaround, users can check input for excessive amount of backslashes in schemas. More than a dozen backslashes per line are atypical. References CWE-1333 For more information If you have any questions or comments about this advisory: Open an issue in python-ldap tracker
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-r8wq-qrxc-hmcm
- Revision 2 · amended ·
Amended from osv record GHSA-r8wq-qrxc-hmcm
- Revision 1 · created ·
Published from osv record GHSA-qfr5-wjpw-q4c4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-46823 Advisory: ReDoS in LDAP schema parser IDs: CVE-2021-46823, GHSA-qfr5-wjpw-q4c4 Record: https://patchnext.com/advisories/cve-2021-46823 (revision 3, source checked 26 Oct 2026, 13:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: python-ldap 3.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI python-ldap: affected < 3.4.0; fixed in 3.4.0 ## Suggested inspection (read-only) - `python -m pip show python-ldap`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on python-ldap. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qfr5-wjpw-q4c4 (OSV record GHSA-qfr5-wjpw-q4c4 lists affected ranges: PyPI python-ldap >=0 <3.4.0 (fixed)) - Verified: https://osv.dev/vulnerability/GHSA-r8wq-qrxc-hmcm (OSV record GHSA-r8wq-qrxc-hmcm lists affected ranges: PyPI python-ldap >=0 <3.4.0 (fixed)) - Verified: https://github.com/advisories/GHSA-r8wq-qrxc-hmcm (GitHub-reviewed advisory GHSA-r8wq-qrxc-hmcm lists affected ranges: PyPI python-ldap >=0 <3.4.0) Commands are suggestions: review each one before running it.
Loading voting…