Skip to content

← Actionable
Medium, CVSS 5.6amended

OpenZeppelin Contracts initializer reentrancy may lead to double initialization

CVE-2021-46320GHSA-88g8-f5mf-f5rj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@openzeppelin/contracts 4.4.1; @openzeppelin/contracts-upgradeable 4.4.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.6 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2021-46320: 1.22% estimated exploitation activity in the next 30 days; percentile 68.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
  • CVE-2022-39384: 0.66% estimated exploitation activity in the next 30 days; percentile 51.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Initializer functions that are invoked separate from contract creation (the most prominent example being minimal proxies) may be reentered if they make an untrusted non-view external call. Once an initializer has finished running it can never be re-executed. However, an exception put in place to support multiple inheritance made reentrancy possible in the scenario described above, breaking the expectation that there is a single execution. Note that upgradeable proxies are commonly initialized together with contract creation, where reentrancy is not feasible, so the impact of this issue is believed to be minor.

Patches A fix is included in the version v4.4.1 of `@openzeppelin/contracts` and `@openzeppelin/contracts-upgradeable`.

Workarounds Avoid untrusted external calls during initialization.

References https://github.com/OpenZeppelin/openzeppelin-contracts/pull/3006

Credits This issue was identified and reported by @chaitinblockchain through our bug…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-9c22-pwxw-p6hx

  2. Revision 1 · created ·

    Published from osv record GHSA-88g8-f5mf-f5rj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-46320

Advisory: OpenZeppelin Contracts initializer reentrancy may lead to double initialization
IDs: CVE-2021-46320, GHSA-88g8-f5mf-f5rj
Record: https://patchnext.com/advisories/cve-2021-46320 (revision 2, source checked 24 Oct 2026, 04:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @openzeppelin/contracts 4.4.1; @openzeppelin/contracts-upgradeable 4.4.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @openzeppelin/contracts: affected >= 3.2.0, < 4.4.1; fixed in 4.4.1
- npm @openzeppelin/contracts-upgradeable: affected >= 3.2.0, < 4.4.1; fixed in 4.4.1

## Suggested inspection (read-only)
- `npm ls @openzeppelin/contracts --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @openzeppelin/contracts-upgradeable --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @openzeppelin/contracts, @openzeppelin/contracts-upgradeable.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-88g8-f5mf-f5rj (OSV record GHSA-88g8-f5mf-f5rj lists affected ranges: npm @openzeppelin/contracts >=0 <4.4.1 (fixed))
- Verified: https://osv.dev/vulnerability/GHSA-9c22-pwxw-p6hx (OSV record GHSA-9c22-pwxw-p6hx lists affected ranges: npm @openzeppelin/contracts >=3.2.0 =3.2.0 <4.4.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…