Skip to content

← Actionable
High, CVSS 7.5

Uncontrolled Resource Consumption in simple_asn1

CVE-2021-45711GHSA-g4h2-4wvh-grc5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (simple_asn1 0.6.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io simple_asn1

    Affected
    >= 0.6.0, <= 0.6.0
    Fixed in
    0.6.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2021-45711: 1.38% estimated exploitation activity in the next 30 days; percentile 72.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An issue was discovered in the simpleasn1 crate 0.6.0 before 0.6.1 for Rust. There is a panic if UTCTime data, supplied by a remote attacker, has a second character greater than 0x7f.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-g4h2-4wvh-grc5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-45711

Advisory: Uncontrolled Resource Consumption in simple_asn1
IDs: CVE-2021-45711, GHSA-g4h2-4wvh-grc5
Record: https://patchnext.com/advisories/cve-2021-45711 (revision 1, source checked 26 Oct 2026, 15:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: simple_asn1 0.6.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io simple_asn1: affected >= 0.6.0, <= 0.6.0; fixed in 0.6.1

## Suggested inspection (read-only)
- crates.io simple_asn1: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on simple_asn1.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-g4h2-4wvh-grc5 (GitHub-reviewed advisory GHSA-g4h2-4wvh-grc5 lists affected ranges: crates.io simple_asn1 >=0.6.0 <=0.6.0)

Commands are suggestions: review each one before running it.

Loading voting…