Out-of-bounds Write in nix
CVE-2021-45707GHSA-76w9-p8mg-j927
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nix 0.22.2, 0.21.2, 0.20.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io nix
- Affected
- >= 0.21.0, < 0.21.2>= 0.22.0, < 0.22.2>= 0.16.0, < 0.20.2
- Fixed in
- 0.20.2, 0.22.2, 0.21.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-76w9-p8mg-j927 lists affected ranges: crates.io nix >=0.21.0 =0.22.0 =0.16.0 <0.20.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.7 · CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-45707: 1.69% estimated exploitation activity in the next 30 days; percentile 77.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
On certain platforms, if a user has more than 16 groups, the nix::unistd::getgrouplist function will call the libc getgrouplist function with a length parameter greater than the size of the buffer it provides, resulting in an out-of-bounds write and memory corruption. The libc getgrouplist function takes an in/out parameter ngroups specifying the size of the group buffer. When the buffer is too small to hold all of the requested user's group memberships, some libc implementations, including glibc and Solaris libc, will modify ngroups to indicate the actual number of groups for the user, in addition to returning an error. The version of nix::unistd::getgrouplist in nix 0.16.0 and up will resize the buffer to twice its size, but will not read or modify the ngroups variable. Thus, if the user has more than twice as many groups as the initial buffer size of 8, the next call to getgrouplist will then write past the end of the buffer. The issue would require editing /etc/groups to exploit,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-76w9-p8mg-j927
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-45707 Advisory: Out-of-bounds Write in nix IDs: CVE-2021-45707, GHSA-76w9-p8mg-j927 Record: https://patchnext.com/advisories/cve-2021-45707 (revision 1, source checked 26 Oct 2026, 15:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nix 0.22.2, 0.21.2, 0.20.2. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io nix: affected >= 0.21.0, < 0.21.2; >= 0.22.0, < 0.22.2; >= 0.16.0, < 0.20.2; fixed in 0.20.2, 0.22.2, 0.21.2 ## Suggested inspection (read-only) - crates.io nix: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nix. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-76w9-p8mg-j927 (GitHub-reviewed advisory GHSA-76w9-p8mg-j927 lists affected ranges: crates.io nix >=0.21.0 =0.22.0 =0.16.0 <0.20.2) Commands are suggestions: review each one before running it.
Loading voting…