Skip to content

← Actionable
Unrated

Command Injection in Apache Kylin

CVE-2021-45456GHSA-hw3m-8h25-8frw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.kylin:kylin 4.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2021-45456: 88.89% estimated exploitation activity in the next 30 days; percentile 99.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Apache kylin checks the legitimacy of the project before executing some commands with the project name passed in by the user. There is a mismatch between what is being checked and what is being used as the shell command argument in DiagnosisService. This may cause an illegal project name to pass the check and perform the following steps, resulting in a command injection vulnerability. This issue affects Apache Kylin 4.0.0.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hw3m-8h25-8frw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-45456

Advisory: Command Injection in Apache Kylin
IDs: CVE-2021-45456, GHSA-hw3m-8h25-8frw
Record: https://patchnext.com/advisories/cve-2021-45456 (revision 1, source checked 26 Oct 2026, 16:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.kylin:kylin 4.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.kylin:kylin: affected < 4.0.1; fixed in 4.0.1

## Suggested inspection (read-only)
- Maven org.apache.kylin:kylin: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.kylin:kylin.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hw3m-8h25-8frw (GitHub-reviewed advisory GHSA-hw3m-8h25-8frw lists affected ranges: Maven org.apache.kylin:kylin >=0 <4.0.1)

Commands are suggestions: review each one before running it.

Loading voting…