RosarioSIS XSS Vulnerability
CVE-2021-45416GHSA-287r-574x-f4h4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (francoisjacquet/rosariosis 8.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist francoisjacquet/rosariosis
- Affected
- <= 8.2.1
- Fixed in
- 8.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-287r-574x-f4h4 lists affected ranges: Packagist francoisjacquet/rosariosis >=0 <=8.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2021-45416: 2.33% estimated exploitation activity in the next 30 days; percentile 83.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Reflected Cross-site scripting (XSS) vulnerability in RosarioSIS 8.2.1 allows attackers to inject arbitrary HTML via the searchterm parameter in the modules/Scheduling/Courses.php script.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-287r-574x-f4h4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-45416 Advisory: RosarioSIS XSS Vulnerability IDs: CVE-2021-45416, GHSA-287r-574x-f4h4 Record: https://patchnext.com/advisories/cve-2021-45416 (revision 1, source checked 26 Oct 2026, 14:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: francoisjacquet/rosariosis 8.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist francoisjacquet/rosariosis: affected <= 8.2.1; fixed in 8.3 ## Suggested inspection (read-only) - Packagist francoisjacquet/rosariosis: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on francoisjacquet/rosariosis. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-287r-574x-f4h4 (GitHub-reviewed advisory GHSA-287r-574x-f4h4 lists affected ranges: Packagist francoisjacquet/rosariosis >=0 <=8.2.1) Commands are suggestions: review each one before running it.
Loading voting…