Skip to content

← Actionable
High, CVSS 8.7amended

Denial-of-service in Django

CVE-2021-45115GHSA-53qw-q765-4fww

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (django 4.0.1, 3.2.11, 2.2.26), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI django

    Affected
    >= 2.2a1, < 2.2.26>= 3.2a1, < 3.2.11>= 4.0a1, < 4.0.1
    Fixed in
    3.2.11, 2.2.26, 4.0.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2021-45115: 2.60% estimated exploitation activity in the next 30 days; percentile 85.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An issue was discovered in Django 2.2 before 2.2.26, 3.2 before 3.2.11, and 4.0 before 4.0.1. UserAttributeSimilarityValidator incurred significant overhead in evaluating a submitted password that was artificially large in relation to the comparison values. In a situation where access to user registration was unrestricted, this provided a potential vector for a denial-of-service attack.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-53qw-q765-4fww

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-53qw-q765-4fww

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-45115

Advisory: Denial-of-service in Django
IDs: CVE-2021-45115, GHSA-53qw-q765-4fww
Record: https://patchnext.com/advisories/cve-2021-45115 (revision 3, source checked 26 Oct 2026, 13:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: django 4.0.1, 3.2.11, 2.2.26. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI django: affected >= 2.2a1, < 2.2.26; >= 3.2a1, < 3.2.11; >= 4.0a1, < 4.0.1; fixed in 3.2.11, 2.2.26, 4.0.1

## Suggested inspection (read-only)
- `python -m pip show django`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on django.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-53qw-q765-4fww (OSV record GHSA-53qw-q765-4fww lists affected ranges: PyPI django >=2.2a1 =3.2a1 =4.0a1 <4.0.1 (fixed))
- Verified: https://github.com/advisories/GHSA-53qw-q765-4fww (GitHub-reviewed advisory GHSA-53qw-q765-4fww lists affected ranges: PyPI django >=2.2a1 =3.2a1 =4.0a1 <4.0.1)

Commands are suggestions: review each one before running it.

Loading voting…