Skip to content

← Actionable
Critical, CVSS 9.8amended

Prototype Pollution in minimist

CVE-2021-44906GHSA-xvch-5gv4-984h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (minimist 1.2.6, 0.2.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm minimist

    Affected
    >= 1.0.0, < 1.2.6< 0.2.4
    Fixed in
    1.2.6, 0.2.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2021-44906: 4.58% estimated exploitation activity in the next 30 days; percentile 91.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Minimist prior to 1.2.6 and 0.2.4 is vulnerable to Prototype Pollution via file index.js, function setKey() (lines 69-95).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-xvch-5gv4-984h

  2. Revision 1 · created ·

    Published from osv record GHSA-xvch-5gv4-984h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-44906

Advisory: Prototype Pollution in minimist
IDs: CVE-2021-44906, GHSA-xvch-5gv4-984h
Record: https://patchnext.com/advisories/cve-2021-44906 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: minimist 1.2.6, 0.2.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm minimist: affected >= 1.0.0, < 1.2.6; < 0.2.4; fixed in 1.2.6, 0.2.4

## Suggested inspection (read-only)
- `npm ls minimist --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on minimist.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xvch-5gv4-984h (OSV record GHSA-xvch-5gv4-984h lists affected ranges: npm minimist >=1.0.0 =0 <0.2.4 (fixed))
- Verified: https://github.com/advisories/GHSA-xvch-5gv4-984h (GitHub-reviewed advisory GHSA-xvch-5gv4-984h lists affected ranges: npm minimist >=1.0.0 =0 <0.2.4)

Commands are suggestions: review each one before running it.

Loading voting…