Cross-site Scripting in Nacos
CVE-2021-44667GHSA-4gr7-qw2q-jxh6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.alibaba.nacos:nacos-common 2.1.0-BETA, 1.4.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.alibaba.nacos:nacos-common
- Affected
- >= 2.0.0-ALPHA.1, < 2.1.0-BETA< 1.4.5
- Fixed in
- 1.4.5, 2.1.0-BETA
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4gr7-qw2q-jxh6 lists affected ranges: Maven com.alibaba.nacos:nacos-common >=2.0.0-ALPHA.1 =0 <1.4.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2021-44667: 0.83% estimated exploitation activity in the next 30 days; percentile 57.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A Cross Site Scripting (XSS) vulnerability exists in Nacos prior to 1.4.5 and 2.1.0-BETA in auth/users via the (1) pageSize and (2) pageNo parameters.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4gr7-qw2q-jxh6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-44667 Advisory: Cross-site Scripting in Nacos IDs: CVE-2021-44667, GHSA-4gr7-qw2q-jxh6 Record: https://patchnext.com/advisories/cve-2021-44667 (revision 1, source checked 26 Oct 2026, 16:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.alibaba.nacos:nacos-common 2.1.0-BETA, 1.4.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.alibaba.nacos:nacos-common: affected >= 2.0.0-ALPHA.1, < 2.1.0-BETA; < 1.4.5; fixed in 1.4.5, 2.1.0-BETA ## Suggested inspection (read-only) - Maven com.alibaba.nacos:nacos-common: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.alibaba.nacos:nacos-common. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4gr7-qw2q-jxh6 (GitHub-reviewed advisory GHSA-4gr7-qw2q-jxh6 lists affected ranges: Maven com.alibaba.nacos:nacos-common >=2.0.0-ALPHA.1 =0 <1.4.5) Commands are suggestions: review each one before running it.
Loading voting…