Insufficiently Protected Credentials in Apache Superset
CVE-2021-44451GHSA-hhm3-48h2-597v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-superset 1.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-superset
- Affected
- < 1.4.0
- Fixed in
- 1.4.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hhm3-48h2-597v lists affected ranges: PyPI apache-superset >=0 <1.4.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hhm3-48h2-597v lists affected ranges: PyPI apache-superset >=0 <1.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2021-44451: 7.86% estimated exploitation activity in the next 30 days; percentile 94.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Superset up to and including 1.3.2 allowed for registered database connections password leak for authenticated users. This information could be accessed in a non-trivial way. Users should upgrade to Apache Superset 1.4.0 or higher.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-hhm3-48h2-597v
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-hhm3-48h2-597v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-44451 Advisory: Insufficiently Protected Credentials in Apache Superset IDs: CVE-2021-44451, GHSA-hhm3-48h2-597v Record: https://patchnext.com/advisories/cve-2021-44451 (revision 3, source checked 26 Oct 2026, 13:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache-superset 1.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-superset: affected < 1.4.0; fixed in 1.4.0 ## Suggested inspection (read-only) - `python -m pip show apache-superset`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-superset. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hhm3-48h2-597v (OSV record GHSA-hhm3-48h2-597v lists affected ranges: PyPI apache-superset >=0 <1.4.0 (fixed)) - Verified: https://github.com/advisories/GHSA-hhm3-48h2-597v (GitHub-reviewed advisory GHSA-hhm3-48h2-597v lists affected ranges: PyPI apache-superset >=0 <1.4.0) Commands are suggestions: review each one before running it.
Loading voting…