lambda-middleware Inefficient Regular Expression Complexity vulnerability
CVE-2021-4437GHSA-m3f4-957x-m785
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@lambda-middleware/json-deserializer 1.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @lambda-middleware/json-deserializer
- Affected
- < 1.1.0
- Fixed in
- 1.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-m3f4-957x-m785 lists affected ranges: npm @lambda-middleware/json-deserializer >=0 <1.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m3f4-957x-m785 lists affected ranges: npm @lambda-middleware/json-deserializer >=0 <1.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.5 · CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2021-4437: 0.45% estimated exploitation activity in the next 30 days; percentile 38.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability, which was classified as problematic, has been found in dbartholomae lambda-middleware frameguard up to 1.0.4. Affected by this issue is some unknown functionality of the file packages/json-deserializer/src/JsonDeserializer.ts of the component JSON Mime-Type Handler. The manipulation leads to inefficient regular expression complexity. Upgrading to version 1.1.0 is able to address this issue. The patch is identified as f689404d830cbc1edd6a1018d3334ff5f44dc6a6. It is recommended to upgrade the affected component. VDB-253406 is the identifier assigned to this vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-m3f4-957x-m785
- Revision 1 · created ·
Published from osv record GHSA-m3f4-957x-m785
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-4437 Advisory: lambda-middleware Inefficient Regular Expression Complexity vulnerability IDs: CVE-2021-4437, GHSA-m3f4-957x-m785 Record: https://patchnext.com/advisories/cve-2021-4437 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @lambda-middleware/json-deserializer 1.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @lambda-middleware/json-deserializer: affected < 1.1.0; fixed in 1.1.0 ## Suggested inspection (read-only) - `npm ls @lambda-middleware/json-deserializer --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @lambda-middleware/json-deserializer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-m3f4-957x-m785 (OSV record GHSA-m3f4-957x-m785 lists affected ranges: npm @lambda-middleware/json-deserializer >=0 <1.1.0 (fixed)) - Verified: https://github.com/advisories/GHSA-m3f4-957x-m785 (GitHub-reviewed advisory GHSA-m3f4-957x-m785 lists affected ranges: npm @lambda-middleware/json-deserializer >=0 <1.1.0) Commands are suggestions: review each one before running it.
Loading voting…