Remote code injection in Log4j
CVE-2021-44228GHSA-jfh8-c2jp-5v3q
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.ops4j.pax.logging:pax-logging-log4j2
- Affected
- >= 1.8.0, < 1.9.2>= 1.10.0, < 1.10.8>= 1.11.0, < 1.11.10>= 2.0.0, < 2.0.11
- Fixed in
- 1.10.8, 1.11.10, 1.9.2, 2.0.11
Maven org.apache.logging.log4j:log4j-core
- Affected
- >= 2.13.0, < 2.15.0>= 2.4, < 2.12.2>= 2.0-beta9, < 2.3.1
- Fixed in
- 2.15.0, 2.12.2, 2.3.1
Maven com.guicedee.services:log4j-core
- Affected
- <= 1.2.1.2-jre17
- Fixed in
- no fixed version recorded
Maven org.xbib.elasticsearch:log4j
- Affected
- >= 6.3.2.1, <= 6.3.2.1
- Fixed in
- no fixed version recorded
Maven uk.co.nichesolutions.logging.log4j:log4j-core
- Affected
- >= 2.6.3-CUSTOM, <= 2.6.3-CUSTOM
- Fixed in
- no fixed version recorded
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jfh8-c2jp-5v3q lists affected ranges: Maven org.apache.logging.log4j:log4j-core >=2.13.0 =2.4 =2.0-beta9 =0 =6.3.2.1 =2.6.3-CUSTOM =1.8.0 =1.10.0 =1.11.0 =2.0.0 <2.0.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2021-44228 to the Known Exploited Vulnerabilities catalog on 2021-12-10.
VerifiedObserved Listed in the CISA KEV JSON feed (dateAdded 2021-12-10).
Severity and exploitation
- Exploitation
- Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
- CVSS
- 10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H/E:H
- EPSS
- CVE-2021-44228: 100.00% estimated exploitation activity in the next 30 days; percentile 100.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Log4j versions prior to 2.16.0 are subject to a remote code execution vulnerability via the ldap JNDI parser. As per Apache's Log4j security guide: Apache Log4j2 <=2.14.1 JNDI features used in configuration, log messages, and parameters do not protect against attacker controlled LDAP and other JNDI related endpoints. An attacker who can control log messages or log message parameters can execute arbitrary code loaded from LDAP servers when message lookup substitution is enabled. From log4j 2.16.0, this behavior has been disabled by default. Log4j version 2.15.0 contained an earlier fix for the vulnerability, but that patch did not disable attacker-controlled JNDI lookups in all situations. For more information, see the Updated advice for version 2.16.0 section of this advisory. Impact Logging untrusted or user controlled data with a vulnerable version of Log4J may result in Remote Code Execution (RCE) against your application. This includes untrusted data included in logged…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jfh8-c2jp-5v3q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-44228 Advisory: Remote code injection in Log4j IDs: CVE-2021-44228, GHSA-jfh8-c2jp-5v3q Record: https://patchnext.com/advisories/cve-2021-44228 (revision 1, source checked 26 Oct 2026, 16:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog. Vendor response: Partial vendor fix; fixed versions by package: org.ops4j.pax.logging:pax-logging-log4j2 2.0.11, 1.11.10, 1.10.8, 1.9.2; org.apache.logging.log4j:log4j-core 2.15.0, 2.12.2, 2.3.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.ops4j.pax.logging:pax-logging-log4j2: affected >= 1.8.0, < 1.9.2; >= 1.10.0, < 1.10.8; >= 1.11.0, < 1.11.10; >= 2.0.0, < 2.0.11; fixed in 1.10.8, 1.11.10, 1.9.2, 2.0.11 - Maven org.apache.logging.log4j:log4j-core: affected >= 2.13.0, < 2.15.0; >= 2.4, < 2.12.2; >= 2.0-beta9, < 2.3.1; fixed in 2.15.0, 2.12.2, 2.3.1 - Maven com.guicedee.services:log4j-core: affected <= 1.2.1.2-jre17 - Maven org.xbib.elasticsearch:log4j: affected >= 6.3.2.1, <= 6.3.2.1 - Maven uk.co.nichesolutions.logging.log4j:log4j-core: affected >= 2.6.3-CUSTOM, <= 2.6.3-CUSTOM ## Suggested inspection (read-only) - Maven org.ops4j.pax.logging:pax-logging-log4j2: check the installed version with your package manager. - Maven org.apache.logging.log4j:log4j-core: check the installed version with your package manager. - Maven com.guicedee.services:log4j-core: check the installed version with your package manager. - Maven org.xbib.elasticsearch:log4j: check the installed version with your package manager. - Maven uk.co.nichesolutions.logging.log4j:log4j-core: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.ops4j.pax.logging:pax-logging-log4j2, org.apache.logging.log4j:log4j-core, com.guicedee.services:log4j-core, org.xbib.elasticsearch:log4j, uk.co.nichesolutions.logging.log4j:log4j-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jfh8-c2jp-5v3q (GitHub-reviewed advisory GHSA-jfh8-c2jp-5v3q lists affected ranges: Maven org.apache.logging.log4j:log4j-core >=2.13.0 =2.4 =2.0-beta9 =0 =6.3.2.1 =2.6.3-CUSTOM =1.8.0 =1.10.0 =1.11.0 =2.0.0 <2.0.11) - Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2021-44228 to the Known Exploited Vulnerabilities catalog on 2021-12-10.) Commands are suggestions: review each one before running it.
Loading voting…