Apache Tomcat Race Condition vulnerability
CVE-2021-43980GHSA-jx7c-7mj5-9438
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat:tomcat 10.1.0-M14, 10.0.20, 9.0.62, 8.5.78), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.tomcat:tomcat
- Affected
- >= 8.5.0, < 8.5.78>= 9.0.0-M1, < 9.0.62>= 10.0.0-M1, < 10.0.20>= 10.1.0-M1, < 10.1.0-M14
- Fixed in
- 10.1.0-M14, 10.0.20, 8.5.78, 9.0.62
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jx7c-7mj5-9438 lists affected ranges: Maven org.apache.tomcat:tomcat >=8.5.0 =9.0.0-M1 =10.0.0-M1 =10.1.0-M1 <10.1.0-M14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2021-43980: 2.36% estimated exploitation activity in the next 30 days; percentile 83.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The simplified implementation of blocking reads and writes introduced in Tomcat 10 and back-ported to Tomcat 9.0.47 onwards exposed a long standing (but extremely hard to trigger) concurrency bug in Apache Tomcat 10.1.0 to 10.1.0-M12, 10.0.0-M1 to 10.0.18, 9.0.0-M1 to 9.0.60 and 8.5.0 to 8.5.77 that could cause client connections to share an Http11Processor instance resulting in responses, or part responses, to be received by the wrong client.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jx7c-7mj5-9438
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-43980 Advisory: Apache Tomcat Race Condition vulnerability IDs: CVE-2021-43980, GHSA-jx7c-7mj5-9438 Record: https://patchnext.com/advisories/cve-2021-43980 (revision 1, source checked 26 Oct 2026, 16:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat:tomcat 10.1.0-M14, 10.0.20, 9.0.62, 8.5.78. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.tomcat:tomcat: affected >= 8.5.0, < 8.5.78; >= 9.0.0-M1, < 9.0.62; >= 10.0.0-M1, < 10.0.20; >= 10.1.0-M1, < 10.1.0-M14; fixed in 10.1.0-M14, 10.0.20, 8.5.78, 9.0.62 ## Suggested inspection (read-only) - Maven org.apache.tomcat:tomcat: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.tomcat:tomcat. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jx7c-7mj5-9438 (GitHub-reviewed advisory GHSA-jx7c-7mj5-9438 lists affected ranges: Maven org.apache.tomcat:tomcat >=8.5.0 =9.0.0-M1 =10.0.0-M1 =10.1.0-M1 <10.1.0-M14) Commands are suggestions: review each one before running it.
Loading voting…