Inefficient Regular Expression Complexity in nltk (word_tokenize, sent_tokenize)
CVE-2021-43854GHSA-f8m6-h2c7-8h9x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nltk 3.6.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI nltk
- Affected
- < 3.6.6
- Fixed in
- 3.6.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-f8m6-h2c7-8h9x lists affected ranges: PyPI nltk >=0 <3.6.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f8m6-h2c7-8h9x lists affected ranges: PyPI nltk >=0 <3.6.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2021-43854: 2.79% estimated exploitation activity in the next 30 days; percentile 86.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The vulnerability is present in PunktSentenceTokenizer, senttokenize and wordtokenize. Any users of this class, or these two functions, are vulnerable to a Regular Expression Denial of Service (ReDoS) attack. In short, a specifically crafted long input to any of these vulnerable functions will cause them to take a significant amount of execution time. The effect of this vulnerability is noticeable with the following example: Which gave the following output during testing: I canceled the execution of the program after running it for several hours. If your program relies on any of the vulnerable functions for tokenizing unpredictable user input, then we would strongly recommend upgrading to a version of NLTK without the vulnerability, or applying the workaround described below. Patches The problem has been patched in NLTK 3.6.6. After the fix, running the above program gives the following result: This output shows a linear relationship in execution time versus input length,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-f8m6-h2c7-8h9x
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-f8m6-h2c7-8h9x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-43854 Advisory: Inefficient Regular Expression Complexity in nltk (word_tokenize, sent_tokenize) IDs: CVE-2021-43854, GHSA-f8m6-h2c7-8h9x Record: https://patchnext.com/advisories/cve-2021-43854 (revision 3, source checked 26 Oct 2026, 13:18 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nltk 3.6.6. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI nltk: affected < 3.6.6; fixed in 3.6.6 ## Suggested inspection (read-only) - `python -m pip show nltk`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nltk. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-f8m6-h2c7-8h9x (OSV record GHSA-f8m6-h2c7-8h9x lists affected ranges: PyPI nltk >=0 <3.6.6 (fixed)) - Verified: https://github.com/advisories/GHSA-f8m6-h2c7-8h9x (GitHub-reviewed advisory GHSA-f8m6-h2c7-8h9x lists affected ranges: PyPI nltk >=0 <3.6.6) Commands are suggestions: review each one before running it.
Loading voting…