Skip to content

← Actionable
Medium, CVSS 6.3amended

vault-cli contains possible RCE when reading user-defined data

CVE-2021-43837GHSA-q34h-97wf-8r8j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vault-cli 3.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vault-cli

    Affected
    >= 0.7.0, < 3.0.0
    Fixed in
    3.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:A/AC:L/AT:N/PR:H/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2021-43837: 5.17% estimated exploitation activity in the next 30 days; percentile 92.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact What kind of vulnerability is it? Who is impacted? vault-cli features the ability for rendering templated values (as explained in the documentation). When a secret starts with the prefix !template!, vault-cli interprets the rest of the contents of the secret as a Jinja2 template. Jinja2 is a powerful templating engine and it's not designed to safely render arbitrary templates. An attacker controlling a jinja2 template rendered on a machine can trigger arbitrary code, making this a Remote Code Execution (RCE) risk. If the content of the vault can be completely trusted, then this is not a problem. Otherwise, if your threat model includes cases where an attacker can manipulate a secret value read from the vault using vault-cli, then this vulnerability may impact you. This does not impact vault itself, except for the fact that the attacker, having an RCE on the machine that executes vault-cli, may abuse the token that vault-cli uses, to read, write or delete other data from the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-q34h-97wf-8r8j

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-q34h-97wf-8r8j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-43837

Advisory: vault-cli contains possible RCE when reading user-defined data
IDs: CVE-2021-43837, GHSA-q34h-97wf-8r8j
Record: https://patchnext.com/advisories/cve-2021-43837 (revision 3, source checked 26 Oct 2026, 13:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vault-cli 3.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vault-cli: affected >= 0.7.0, < 3.0.0; fixed in 3.0.0

## Suggested inspection (read-only)
- `python -m pip show vault-cli`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vault-cli.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-q34h-97wf-8r8j (OSV record GHSA-q34h-97wf-8r8j lists affected ranges: PyPI vault-cli >=0.7.0 <3.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-q34h-97wf-8r8j (GitHub-reviewed advisory GHSA-q34h-97wf-8r8j lists affected ranges: PyPI vault-cli >=0.7.0 <3.0.0)

Commands are suggestions: review each one before running it.

Loading voting…